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Preface
Welcome to Version 5 Photo Studio!
This new generation product enables you to easily and interactively create photorealistic
images and simple animations of a product.
Thanks to its ease of use and to the interactive preview of rendering specifications as they are
applied, Photo Studio is the perfect tool for any "non specialist" user who wish to deliver a high
quality photorealistic image at any time and without the help of rendering specialists.
Photo Studio contributes to enhance project collaboration by enabling any user to produce
and share quality representations of their ideas. By giving a realistic simulation of the model
appearance, it can also be used to validate the quality of the design at any time during the
product development process.

Using This Guide
More Information

Using This Guide
This guide is intended for any users wishing to generate photorealistic images of products.
All users should be familiar with basic Infrastructure concepts such as document windows,
standard and view toolbars as well as the 3D compass.
This guide is organized as follows:
Getting Started tutorial provides information for starting a Photo Studio session
Basic Tasks section guides you step-by-step through basic procedures such as
managing cameras, light, pictures, and so on.
Advanced Tasks section explains how to manage a scene
Workbench Description describes the Photo Studio menu bar and toolbars
Customizing contains information allowing you to customize your personal environment.
Glossary provides keyterm definitions
Index provides a list of terms specific to product image and animation management.

Where to Find More Information
Prior to reading this book, we recommend that you read the Infrastructure User's Guide.
You may also find useful to read the CATIA - Real Time Rendering User`s Guide that allows
you to define material specifications that will be shared across your entire product development
process as well as map materials onto products to produce photorealistic images.
Certain conventions are used in the documentation to help you recognize and understand
important concepts and specifications.

Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you
recognize and understand important concepts and specifications. The following text
conventions may be used:
The titles of CATIA documents appear in this manner throughout the text.
File -> New identifies the commands to be used.
The use of the mouse differs according to the type of action you need to perform.
Use this
mouse button, whenever you read
Select (menus, commands, geometry in graphics area, ...)
Click (icons, dialog box buttons, tabs, selection of a location in the document
window, ...)
Double-click
Shift-click
Ctrl-click
Check (check boxes)
Drag
Drag and drop (icons onto objects, objects onto objects)
Drag
Move
Right-click (to select contextual menu)

Graphic conventions are denoted as follows:
indicates the estimated time to accomplish a task.

indicates a target of a task.
indicates the prerequisites.
indicates the scenario of a task.
indicates tips

indicates a warning.
indicates information.
indicates the end of a task.
indicates functionalities that are new or enhanced with this Release.
Enhancements can also be identified by a blue-colored background in the
left-hand margin.

What's New?
Basic Tasks
Shooting
Enhanced: shooting quality definition
Render
Enhanced: Stop icon
Stickers
Enhanced: ergonomic improvements to the sticker interface
New: you can now customize the sticker default image
Materials
Enhanced: material properties

Advanced Tasks
Scene Tuning
New: tuning light sources for rendering
New: tuning materials for rendering
New: you can browse the Scene catalog

Workbench Description
New: Apply Material toolbar now includes the Catalog Browser

Getting Started
The following tutorial aims at guiding you when you open the Photo Studio workbench for the
first time.
It provides 3 step-by-step tasks for:

Entering the Rendering Workbench
Loading Products
Creating a Quick Render

All together, these tasks should take 10 minutes to complete.

The result will look like this:

Entering the Rendering Worbench
This first task will show you how to open the Rendering workbench.
The only pre-requisite for this task is to have a current Version 5 session running.

1. From the Start menu, select the Infrastructure -> Rendering commands.
The Rendering workbench is displayed:

Now, let`s perform the next task to learn how to load documents in your Photo
Studio workbench.

Loading Products
This task will show you how to load products in your Rendering workbench.
Make sure that the Shading and Materials options are checked by selecting the
View->Render Style->Customize View command.
1. From the Insert menu, select the Existing Component... command. The Insert an
Existing Component dialog box is displayed.

You can also right-click the product in the
specification tree then select the Components ->
Existing Component... contextual menu.

2. Select "Products" in the "Files of type" field as shown in the above image.
3. Select the GettingStarted.CATProduct.
4. Click Open.

The product is loaded in the Rendering workbench.

Creating a Quick Render
This task will show you how to very simply create a nice image of your product.

If you did not follow the steps 1 to 4 in the previous task, open the
GettingStarted.CATProduct.
Make sure that the Shading and Materials options are checked by selecting the
View->Render Style->Customize View command.
The product looks like this:

1. Click the Quick Render icon

.

The Rendering Output window opens to display the rendered image. The
image resolution is the one of the window containing your product.

A message indicates the name and the location of the image.
2. Click OK to close the window.

Basic Tasks
The Basic Tasks section shows how to use Photo Studio and is intended for the end-user.
Camera Management
Light Management
Picture Management
Stickers
Animations
Environment Management
Shooting
Materials

Camera Management
Creating a Camera from a Viewpoint

Creating a Camera from a Viewpoint
The camera enables you to specify a viewpoint from which a photorealistic image will be
computed. This task will show you how to create a camera and manage its specifications.
Open the DISCMAN.CATProduct document.
1. Click the Create Camera icon

. The camera is created at the current viewpoint.

2. Click the Camera item in the Specification Tree and rotate the model to see the
camera symbol:

This standard visualization is not affected by any change of scale ("zoom").

You can create several cameras at
different locations to have different
viewpoints.
The camera which is taken into
account to render a given image is
said to be active. Any other camera
is inactive.
3. Use the two spheres and the two squares displayed in green on the 3D
representation to interactively manipulate and position the camera.
This visualization is affected by changes of view scale (zoom) and is activated
when selecting a camera in the scene or in the specification tree. Otherwise,
all elements are set to the standard visualization.

Conical camera
Pyramid height = focal length
and
Pyramid base = film dimensions

Cylindrical
camera
Plane = film dimensions

the source point (1) rotates the camera around its target point
the target point (2) rotates the camera around its source point
the source green square translates and rotates the camera around its
target point
the target green square translates and rotates the camera around its
source point

Cameras are needed to render and view a scene. "An image is worth a
thousand words": the better the camera is positioned, the more accurate the
saying is.
4. Select the camera in the Specification Tree then right-click and select the
Edit->Properties commands. The Properties panel is displayed. You can also
specifies the camera view directly inside the preview window by zooming, rotating or
panning the view.

5. In the Lens tab, select the lens Type: Perspective or Parallel, i.e. to obtain a conical
or a cylindrical projection. The Preview area shows the result of your selection
accordingly.
A conical camera is equivalent to a standard camera, with a non-zero focal
length.
Parallel lines in the camera line of view appear to intersect at the same point.
Perspective cameras are used in most cases since they are close to the
human vision.
In the case of a cylindrical camera, parallel lines never appear as intersecting.
These cameras are mainly used to define architectural viewpoints.
6. Specify the Focal Length, which determines the field of view, in millimeters.
In a cylindrical projection, the focal length is replaced by a zoom factor which
determines the scale of view (i.e. "Scale" appears instead of "Focal Length" in the
dialog box).
7. Click the Position tab to define the target and origin position.

You can define the Origin and the Target position in millimeters along the X, Y
and Z axes.
The Feature Properties tab provides general information on the currently
selected camera, e.g. its name, its creation date, etc.

8. Click OK when finished.
9. In case you want to position yourself behind the camera and observe the captured
image, select the Window -> Camera Window command: a new window displaying
the camera viewpoint is opened. When you manipulate the handler in this window,
the camera is simultaneously positioned in the main window.
10. You can choose three arrangements for the opened windows, i.e. horizontal, vertical
and cascading by selecting the following commands from the menu bar:
Window -> Tile Horizontally
Window -> Tile Vertically
Window -> Cascade

You can double-click the Camera
item in the specification tree to
position the camera from the current
point of view.

Light Management
Defining a Light Source

Defining a Light Source
This task shows you how to create a light and define its parameters. Lights let you
illuminate the objects to be rendered as you wish for example, by highlighting a specific
element in your scene, thus focusing the viewer`s attention.
Open the Lamp.CATProduct document.
You can choose between three different types of light sources: spot, point and
directional.

1. Click the Create Spot Light icon

to create a source with a conical shape.

This light source is located at a given place, emitting the light isotropically
inside a cone of influence determined by the privileged direction of
illumination (forming the axis of revolution) and the angle that the edge of the
cone forms with this axis.
Spot light sources are mainly used to simulate spot light (the most frequently
used lights) and are useful for tuning the lighting of each object individually.

You can also

or
click the Create Directional Light icon

click the Create Point Light
icon:

:

this creates a source situated at a
given point, emitting light
isotropically, i.e. in all directions.
This light source type is mainly used
to simulate light bulb, for instance.

this creates a light source coming from a
given direction, generating constant
intensity parallel lighting. This light
source type is mainly used to simulate a
global lighting as the sun does.

Note: you can click anywhere in the geometry area to see the light symbol:

Spot light
Punctual light

Directional light

Direction vector represents the privileged direction of illumination of the
source for spot and directional light sources. It is visualized by an arrow
whose origin is the anchoring point of the source.
Anchoring point is the position of the light source and is represented by a
small star. When the source is characterized by a direction, the anchoring
point coincides with the origin of the arrow.
In the case of a spot or punctual light source, the anchoring point physically
localizes the source. In the case of a directional light source, it can be used
(with the target point) to define the illumination direction.
2. As for cameras, you can interactively manipulate a light as you do with cameras.

the source point (1) rotates the spot around its target point
the target point (2) rotates the spot around its source point
the upper green square translates and rotates the spot around its
target point
the lower green square translates and rotates the spot around its
source point
the dotted lines define the lighting attenuation for the spot and
punctual lights. By default, there is no attenuation: the illumination
starts at the source point and ends at the target point. The dotted lines
indicate where lighting attenuation starts, ending with a null intensity at
the plain lines. The two pictures below explain how to modify this
attenuation:

Position your pointer over the
dotted line, then click and drag
the vertical segment to modify
the attenuation starting point.

Position your pointer over the
dotted line then click and drag
the curved segment to modify the
attenuation angle ratio.

3. Select the light then the Edit->Properties command to access the Lighting tab in
order to edit the lighting parameters:

Selecting the light in the specification tree then the
Properties or the Light object-> Definition... command from
the contextual menu also opens the Properties panel.

4. Use the slider to modify the color intensity then click the
choose another color (the default color is white):

button if you want to

You can enter a value comprised between 0 and 255 for any of these fields.

As you can see it in the above picture, two color system models are used:
HLS (Hue, Saturation, Luminance) model is an intuitive, easy to use
tool for describing or
modifying a color.
Hue is the "color" of the color. It is the name by which the color is
designated and is used to
define the desired color.
Saturation is the intensity of the color. The higher the number, the
more intense the color.
It is used to tune the purity of the color.
Luminance is the brightness of the color, i.e. the degree to which the
pure color is diluted by
white or black. The larger the number, the lighter the color. It is used to
adjust intensity.
RGB (Red, Green, Blue) model is a more physical model. It is based
on the tri-stimulus theory
of the human perception system. This model is usually used to definr,
with a high precision, the
three primary components of the color.
5. Click OK to confirm and close the Color dialog box.

You can check the Shadows option if you want that light to
produce shadows in the rendered image.

6. The Shape area enables you to define the half-angle of the cone, that is the angle
between the axis of revolution and the cone edge (for spot light sources only).
The angle is a value between 0 and 180 degrees. This means that a value of 180
degrees would generate a light source equivalent to a punctual light source.

7. The Attenuation area lets you define
Attenuation End: defines in millimeters the maximum distance for
light attenuation (i.e. the distance to the center from which the light
source does not illuminate)
Attenuation Start Ratio: defines as a ratio the minimum distance for
light attenuation. For example:
0 corresponds to an attenuation starting from the center
0.5 corresponds to an attenuation starting from the middle
1 corresponds to an attenuation starting from the end, i.e. a null
attenuation
Attenuation Angle Ratio: defines as a fraction of the light angle the
angle to the light axis from which the light starts to attenuate. For
example:
0 corresponds to an attenuation starting from the axis
0.5 corresponds to an attenuation starting from the half-angle
1 corresponds to an attenuation starting from the end, i.e. a null
attenuation.
8. Check the Shadows option if you want to enable shadow casting. When it is Off,
shadows are not calculated for this light source.
Note: this option is used for rendering only.

9. Click the Position tab to define the light source anchoring point and the point to
which the source is directed, respectively in the Origin and Target areas.
You can define this position in millimeters along the X, Y and Z axes.

The Feature Properties tab provides general information on the currently
selected light source, e.g. its name, its creation date, etc.
10. Click OK to apply the defined parameters to your light source.

Light sources which are taken into account for rendering are
said to be active. Otherwise, they are inactive.
To activate or deactivate a light source, simply select it in
the specification tree then check or uncheck the Light On
option from the contextual menu.

Picture Management
Managing Picture Sequences
Saving Pictures

Managing Picture Sequences
This task explains how to manage pictures when rendering a product.

Open the PHONE.CATProduct document.
from the View->Render Style menu in order
Select the Apply Customized View icon
to check that the Shading and Materials options are on.

1. Click the Render Shooting icon
2. Click the Render Single Frame icon
and the processing starts:

to open the Render dialog box.
. The Rendering Output window opens

You can also click the Quick Render icon
render an image.

to

3. Click the Fit All In icon
to zoom the current view out so that the whole
document fits into the available space in the viewer area.
You can also zoom in or out the current view with your mouse as shown
below:

If the rendering computation takes too much time,
you can interrupt it by clicking the Stop icon

.

Note: you can not interrupt the computation as long as the pre-processing
phase is not finished.
By default, the image is saved as CatiaRender.tif in a temporary. If you wish
to modify the name and the default location, please refer to the next task that
learns you how to save pictures.

Saving Pictures
This task explains how to save your image once rendered.
1. Click the Save icon

to open the Save As dialog box.

2. Navigate to the desired location then enter the image name as well as the format in the
appropriate fields.
3. Click Save.
The image is saved.
For more information on saving documents for the first time or under another name,
refer to the Infrastructure Version 5 documentation.

Modify the default name and location of images
rendered with a shooting

1. Click the Create Shooting icon
to open the Shooting definition dialog box.
2. Under the Frame tab, select the "On disk" option and specify the new path and the new
name of the image.

The supported formats are: .rgb, .bmp, .jpg and .tif. If you do not specify any
extension for the file, the default format will be .tif.
Note: the image names of a turntable animation sequence are based on the path and
name defined above. Image names are then prefixed with frame numbers: for
instance, for an animation containing 3 frames, choosing MyTurntable.tif for the image
name will produce MyTurntable_0001.tif, MyTurntable_0002.tif and
MyTurntable_0003.tif .

3. Click OK.
The default location is modified.

Images rendered in .tif format can easily be used for compositing
thanks to alpha channel support. The image pixels that do not
cover any geometrical object have a transparent alpha channel,
thus allowing to nicely embed the rendered image in any other
image used as background.

Modify the default path when using a quick render
picture
1. Select the Tools->Options... command.
2. Choose the Infrastructure category.
3. Click the Rendering subcategory the select the Output tab:

4. In the Output area, select the "On disk" option then specify the new path and the new name
of the image.

You can also click the
icon to display the Open dialog box
and navigate to the desired location.
5. Click OK.
The default location is modified.

Stickers
Applying Stickers
Modifying Stickers

Applying Stickers
This task explains how to apply a sticker onto a face.
Open the DISCMAN.CATProduct.
Select the Tools->Options command then check the Highlight faces and edges option in
the Visualization tab. This option enables to highlight the sticked face.
from the View->Render Style menu in
Select also the Apply Customized View icon
order to check that the Shading and Materials options are on.

1. Click the Apply Sticker icon

.

An empty sticker is displayed in the specification tree:

2. Double-click the root product to apply the sticker (you apply stickers on contextually
edited products).
3. Select the empty sticker in the specification tree then choose the Stick command
from the contextual menu to display the Stick dialog box:

4. Select the 3D geometry location where you want to apply the sticker:
for a V5 model, you can select either a single face in the 3D window or
an entire product
in the specification tree
for a V4 model, you can select a face or the entire product as well.
Note: when the Visualization Mode is active, you can only select an entire
product. Activate the Edit Mode to be able to select a single face.

The sticker icon changes in the specification tree...

...and a default sticker is applied onto the element you selected:

The compass is automatically attached to the gizmo and lets you modify the
sticker orientation if you are working in Planar Projection mode only.
Once the dialog box is closed, you can still use the compass by selecting the
sticker in the specification tree then dragging and dropping the compass onto
the sticker:

The application of a sticker onto the entire product
will result in a longer response time when
manipulating geometry.
5. In the Mapping tab, select the projection Type: UV or Planar.
along the UV axis: the sticker image will be projected on the selected
geometry according to the isoparametrics, i.e. the curves
planar: the image will be projected according to a plane.
Note: sticking on an entire product forbids the use of UV projection thus the
Planar Projection will be the only available option.

In the case of .cgr models, you will have to select the
entire object and thus only the Planar Projection
option will be available.

If you chose the Planar Projection, the next step is to define the mapping
preview in the Gizmo Position area.
The arrow of the mapping preview indicates the projection direction and limit:
it defines an infinite half space where the image will be shown. The mapping
preview behaves a bit like a headlight illuminating half of the space with the
image:

Click the Center button to position the gizmo at the
center of the selected geometry bounding box.

6. In the Translation area, set the gizmo position along the U, V and W axes.
7. In the Rotation area, set the gizmo rotation on the U, V and W axes. The W axis
represents the normal to the surface.
You can use the Reverse Normal option to invert the normal.
The Flip U and Flip V options lets you invert respectively the U and V
direction.

8. Click the Adjustment tab:

9. In the Size area, define the Scale and the Ratio of the sticker.
The Keep Texture Ratio checkbox enables you to keep the image
proportional to its original resolution.

10. In the Layout area, define the sticker Orientation.
You can also define an Offset along the U and V axes.

11. Click OK to validate your parameters.

In case of a product containing several part instances, once you applied a
sticker onto one of these part instances you cannot apply it onto same level or
upper level part instances.

In the above example, once a sticker has been applied onto Part8, you cannot
apply it onto either Part8.1 nor Part 3.1 or Part2.

You can create as many stickers as you wish on the
same geometry and make them overlap each other,
the last sticker created being placed on the top.

You are now ready to modify the sticker properties.

Modifying Stickers
This task explains how to modify the sticker properties such as the lighting or the
projected image, for instance.

Open the DISCMAN.CATProduct and apply a sticker as explained in Applying Stickers.

1. Select the sticker in the specification tree then choose Properties from the
contextual menu.
The Feature Properties tab provides general information on the currently
selected sticker, e.g. its name, its creation date, etc.
The Rendering tab enables you to modify the Mapping, Adjustment and
Lighting parameters:

The Mapping and Adjustment parameters
displayed in this dialog box are identical to those
contained in the Stick dialog box, except that you
can not manipulate the viewpoint.

2. If you want to apply an image to the sticker, click the ... button to open the File
Selection dialog box.
The supported image formats are .bmp, .rgb, .jpg and .tif (this format
supports transparency so that you can see the underlying stickers and
geometry in the transparent areas of your image).
3. Navigate to the image you wish to apply then click Open.
The name, the path and the graphical representation of the chosen image are
displayed in the Texture area:

Whatever image format you choose, you can check the "Use Transparent
Color" option then click the
dialog box:

icon to open the Pick Transparent Color

This dialog box lets you select the color on which the transparency will be
applied after clicking OK:
Note: the default transparent color is Black.

4. Click the Lighting tab to modify the following parameters: color, luminosity, contrast,
shininess and transparency.

For more information on these parameters, refer to the Using Materials for
Rendering task in this guide.

5. Click Apply to validate your definition:

The new sticker properties are applied onto the object.

6. Click the Quick Render icon

to display a rendered image of the sticker.

7. Click OK to close the Rendering Output window.

Animations
Creating a Turntable
Defining Animation Parameters
Previewing and Rendering a Turntable

Creating a Turntable
This task explains how to create a turntable which is the preliminary step before
rendering an animation.
A turntable lets you generate a movie of your model, permitting a better analysis of the
design quality. It is a set of successive images. The movie generated consists in a
rotation of the active camera around an axis.

Open the LAMP.CATProduct document then hide the environment display by clicking the
Environment 1 in the specification tree then selecting the Hide/Show contextual menu.

1. Click the Create Turntable icon

to open the Turntable dialog box.

The turntable symbol is displayed on the product:

You can now define the model rotation axis. The entire product geometry will
be able to rotate around that axis.
2. Position the turntable along the x, y, and z axes by dragging it to the desired
location using the compass:

3. Rotate the turntable along the u, v and w axes:

4. In the Turntable dialog box, indicate the rotation Start and End angles in degrees.
By definition, the turntable is a simple rotation animation. The rotation can be
limited to less than 360 degrees (for instance a half-turn, that is 180 degrees).
The end angle is identified by an arrow.

Note: you can change the rotation direction by clicking the Reverse Direction
button.

5. Click OK.
The turntable is created and you are now ready to define the animation
parameters.

Select the turntable axis in the specification tree then Axis
object -> Definition... from the contextual menu to edit the
turntable rotation axis.

Defining Animation Parameters
This task shows you how to define animation parameters.

1. Click the Create Shooting icon
2. Click the Animation tab.

to open the Shooting Definition dialog box.

3. Select the simulation to be rendered from the pulldown list.
4. Key in the complete animation Duration in seconds.
This gives you the feedback of the effective animation lapse time. It depends on
the number of frames per seconds specified in the scene.
The default value (twenty-five frames per seconds) displayed in the Duration field
is the standard number of images used on a tape recorder.
5. Indicate the Frequency of computation according to the total number of frames in the
animation.
6. In the Frame count field, choose the number of frames that are going to be replayed in
the animation.

7. In the Compute field, indicate whether you wish to compute All frames or only a
specified number of frames. In that case, you have to enter the start and end frames as
well as the step between the computed frames.
8. Click OK.
The shooting is defined and you can now preview and render your animation.

Previewing and Rendering a Turntable
This task shows you how to animate a product in a simulation once you have defined the
turntable and the animation parameters.
1. Select the turntable axis.
2. Click the Simulation

icon. The Edit Simulation dialog box appears:

3. Move the turntable as you wish using the compass.
4. Click the Insert button to record the desired shots in your animation.
As soon as you insert your first keyframe, the dialog box buttons are grayed
out and let you modify, delete or skip the current shot by clicking the
appropriate button.

For more information on animating in a simulation, refer to
Animating Scene Elements in a Simulation in this guide.

5. Keep on inserting keyframes then preview the animation by clicking the Play
forward

button.

When you run the simulation, the animated object rotates around the
turntable axis. Just click the picture below to run the animation:

6. Click the Render Shooting icon
box opens.

to render your animation. The Render dialog

7. Click the Render Animation icon

.

The animation is rendered and saved under a default location:

You can also render an animation by selecting the desired shooting in the
specification tree then clicking the Render Animation contextual menu.

Do not forget to select the corresponding turntable in the
Shooting Definition dialog box as shown below, otherwise the
Render Animation icon will be grayed:

Environment Management
Creating an Environment
Managing Walls
Defining the Wallpaper
Previewing an Environment

Creating an Environment
This task will show you how to create an environment. Three environment types are available: box,
sphere and cylinder.
An environment is a simplified simulation of a landscape surrounding your model and directly reflected
by your model. It is an efficient way to get a very quick feedback of the illumination behavior of your
model and check its integration in its final environment. For example, placing neon lights as a
3D-texture on the ceiling will be used for car body design, while referring to a picture of a Norvegian
forest for the walls will produce an impressive marketing image of a newly designed chainsaw.

Open the RED-CAR.CATProduct document.

1. Click the Create Box Environment
icon if you want to create an environment with a
rectangular shape (to represent a room for example).
2. Zoom out then click anywhere in the geometry area to deselect the environment.

You can also

click the Create Sphere Environment
icon if you want an environment being a
non-dimensional sphere with two
hemisphere: north and south (to simulate
a sky for example).

icon if
click the Create Cylinder Environment
you want an enviroment having a cylindrical
shape:

Showroom environments (square or cylindrical shape) correspond to a square or cylinder
room without windows, with a texture or an image on the walls, floor and ceiling.
This type of environment is a very efficient tool for design study of very close reflection, for
instance, reflection of rows of neon lights on a car body.
Their size can be set and they can be positioned at a desired location.
They are always visible and will appear as other geometrical elements of the model at their
defined location.
Sky-ground environments (spherical shape) will be used to simulate the reflections of a
"real world" onto the geometry. Texture simulating grounds or skies will provide good
results.
They are sizeless: they totally surround the model, whatever its size, whatever their
location. They can be positioned, not for rendering reasons, but to define the turntable axis.

As soon as you create an environment, it
becomes the active one. Any previously created
environment is deactivated in the specification
tree, only one active environment being taken into
account at rendering time.

In our example, Environment 2 has been
created and Environment 1 is
deactivated.
To activate an environment, just select it
in the specification tree then select the
Environment Active command from the
contextual menu.

3. Position your pointer over the edges then use the green segments
resize the environment walls:

displayed to

click and drag a segment to resize the walls according to the edges
shift-click and drag a segment to resize the walls according to the center.
4. Select the environment in the specification tree then right-click and choose the Edit -> Properties
commands. The Properties panel is displayed.
5. The Dimensions tab enables you to define the Length, Width and Height of the walls in
millimeters.

6. Click the Position tab to interactively define:
the environment translation from the Origin along the X, Y or Z axis.
the environment translation along the X, Y, or Z Axis.

The Feature Properties tab provides general information on the currently selected
environment, e.g. its name, its creation date, etc.

You can also interactively position your
environment by dragging the compass and
dropping it onto the environment.

Managing Walls
This task will introduce wall list management.
Open the RED-CAR.CATProduct document and create an environment as explained in
Creating an Environment.
1. In the specification tree, select an environment wall (or select it directly in the 3D
window).

2. Right-click to display the contextual menu then uncheck the Wall Active option. The
selected wall is grayed in the specification tree and is not taken into account at
rendering time, as shown in the example below:

Only the edges of the deactivated wall are displayed in the environment
representation except if you have specified to display inactive environments
(select the Tools->Options->Product commands then the Rendering tab).

The geometry shadows are projected onto
environment flat walls.

Defining the Wallpaper
This task will show you how to associate images to your environment walls.

Open the RED-CAR.CATProduct document and create an environment as explained in
Creating an Environment.

1. Select any wall of the environment on which the wallpaper should be defined.

Note: As far as showroom environments are concerned, you can apply a
different texture to each wall of the environment.
2. Click the Apply Material icon

to display the Library window.

The material must have a texture, otherwise an
error panel will be displayed.

3. Click the Construction tab, for example.
4. Select Marble Paving.

5. Click Apply Material to map the image texture of the material onto the selected wall.
6. Repeat these steps for the other walls if you want to.

Instead of clicking Apply, you can also use the
contextual menu then copy the material before
pasting it or drag and drop the material directly
onto the wall.

7. Select the Apply Customized View icon
in the View ->Render Style menu. The
Custom View Mode dialog box is displayed.

8. Make sure that the Shading and Materials options are checked.
9. Click OK.
The material texture is mapped onto the selected wall.

In the above example, we have applied the following materials: Marble
Paving and Strip Wall.
10. To modify the mapped texture properties, right-click the corresponding environment
wall in the specification tree then select the Properties or the object->Definition...
command from the contextual menu.
The Properties dialog box is displayed:

The Texture tab lets you modify the Image Name as well as the material
Scale, Position and Orientation.

For more information, please refer to the
Modifying Materials section in the CATIA - Real
Time Rendering User`s Guide.

11. Click the Lighting tab and check the "Shadows" option if you want to enable
shadow casting on the wall.

When the option is off, the wall is visible even if not illuminated.
Note: this option is used for rendering only.
12. Click OK or Apply then OK to validate and close the Properties dialog box.

Previewing an Environment
This task will show you how to preview the environment reflections.

Open the RED-CAR.CATProduct document then create an environment with wallpapers as explained in
Defining the Wallpaper.

1. Select the Tools->Options... command.
2. Choose the Infrastructure category.
3. Click the Rendering subcategory. The Display tab opens:

4. In the Dynamic Reflections area, check the "Enable dynamic environment reflections" option.
This option enables you to activate/deactivate the update of environment reflections on
reflecting objects (i.e. those having a non null reflectivity) when the viewpoint is changed.

In order to see environment reflections, an object must be
reflecting and thus having a non-zero reflectivity coefficient.

5. Indicate the texture size in pixels used when the product geometry is moved (e.g during a zoom,
a translation, etc.) and when it is still using the "Texture size while moving" and "Texture size in
static" options, respectively.
6. Specify the texture update threshold in degrees in the "Update when viewpoint rotated more
than..." field.
7. Indicate the number of texture Computation passes.
For more information on setting dynamic reflection display, refer to Rendering in the CATIA
- Infrastructure User`s Guide.
Here is an example of environment reflections on the RED-CAR product:

If part of an environment has no texture or image, this part
has no effect during computation of the environment color.

Shooting
Setting Image Quality Parameters

Setting Image Quality Parameters
This task shows how to define the rendering style and quality parameters.
Open the TuningLightsEnd.CATProduct document.
Make sure that the Shading and Materials options are checked by selecting the View->Render Style->Customize View
command.

1. Click the Create Shooting icon

to open the Shooting Definition dialog box.

Under the Frame tab, the Scene area lets you specify the elements to be rendered as well as the way of
rendering them. By default, the active environment and any other active source are rendered.
2. In the the appropriate fields of the Scene area, select the Camera, Environment and Available Lights you want to
render. A preview of the selected environment and the camera view is displayed.
If no light is Selected, a default directional light orthogonal to the image plane will be used (therefore producing
very few shadows).

3. In the Image size area, define the size of the rendered image using the slider or manually. The number of pixels and
the ratio are linked together. Whenever you change the pixel number, the ratio value is adjusted according to this
number and reciprocally.

You can also use the Predefined format option to
retrieve standard ratios. The corresponding Ratio is
displayed.

4. In the Output area, check the "On disk" option if you want to modify the name of the computed image. By default, it is
saved in a temporary folder under the name "CatiaRender.tif".
The "On disk" option also lets you change the default location. For more information, refer to the Saving Pictures
task in this guide.
5. The Quality tab lets you specify rendering, shadow and accuracy parameters, all of them impacting the rendering
computation duration.

6. Indicate the maximum reflections number.
For instance, if you choose 2 and have two parallel mirrors in your scene, you will see the reflections of the reflections
in each mirror ; choosing 1 instead, you will not see the secondary reflections.

No texture rendering means that only the material
lighting characteristics will be taken into account for
the rendering and the environment wall texture are
not rendered as well. This option can be used to
speed up rendering at early stage for example.
If you check the "Show shadows" option, only the
shadows produced by the active lights will be
rendered, otherwise no shadows are computed. This
can be useful to speed up rendering.

Now, let`s define the accuracy parameters that control the oversampling of the final image:
7. Select the accuracy type.
Predefined: sets a fixed sag value for calculating tessellation on all objects.
a low value means that a very fine mesh is used to render surfaces, but the drawback is that
pre-processing and rendering will take more time
a high value means that a very coarse mesh is used, but the advantage is that pre-processing
and rendering will take less time.
Custom: the Custom parameters are defined through three values: a minimum number of samples, a maximum
number of samples and a threshold.
minimum sample: specifies the minimum number of samples, i.e. rays, taken at each corner of
a pixel square. In our example, we have chosen a minimum of 1 ray at each corner of a
square of 4 × 4 pixels
threshold: specifies the percentage over which an oversampling is done if the contrast in any
RGB component between the currently calculated pixels and the neighboring pixels weighted
by their sum is greater than this threshold.
The lower this value, the more oversampling and the longer the rendering time
maximum sample: specifies the maximum number of samples, i.e. rays, per pixel. In our
example, we have chosen a maximum of 1 ray per pixel.
The preview area to the right shows you the effect of each setting.

Note that anti-aliasing sets a better oversampling.
Anti-aliasing modifies the appearance of lines in
order to make the jagged edges look smoother. To
do so, the square pixels composing the lines are put
in shades of gray or in-between color.

8. Click the Animation tab to define the animation parameters.
For more information on the animation, refer to the Defining Animation Parameters task in this guide.

9. Click OK.
The next step is to render the shooting you have defined.

10. Click the Render Shooting icon
to open the Render dialog box.
A summary of the selected scene characteristics is displayed.

11. Select a shooting then click the Render Single Frame icon
or the Render Animation icon
type of render you wish to create.
The Rendering Output window opens and displays the rendering result.

, depending on the

Note: you can also render an animation or a single frame by selecting the desired shooting in the specification
tree then clicking the Render Animation or the Render Single Frame contextual menu.
The following images illustrate different types of rendering:

Textures off, two active lights, shadows off and an
average accuracy.

Textures on, two active lights, shadows on,
anti-aliasing off and the lowest accuracy.

Textures on, two active lights, shadows on
and the lowest accuracy.

The

Textures on, two active lights, shadows on
and an average accuracy.

icon identifies the most recently rendered shooting in the specification tree, the other shootings being

identified with the

icon.

Click the Redo Render
icon if you wish to redo
the last render you have made, whether it was a
single frame or an animation.

Materials
Using Materials for Rendering

Using Materials for Rendering
This task aims at showing you how to define the material attributes for a rendering.

Open the PHONE.CATProduct document.

You can apply a material to each instance within a CATProduct. This functionality is
especially relevant for rendering purposes since it lets you apply a different texture
to each instance. Therefore, there will be as many materials as instances. The
material preview will however display the last material applied to the instance.

1. In the specification tree, select the plus sign besides the item referred to as "Top Shell".
2. Right-click the Top Shell material then select the Properties command.
The Properties dialog box is displayed:

5. Click the Rendering tab to define the Lighting parameters:
Ambient: the intensity of light diffused in any direction by the object, even if not lit by any light source. The
intensity is defined by a coefficient (with a value between 0 and 1).
This parameter affects the whole object, including the shadowed area.
Diffuse: the intensity of light diffused by the object when lit by light sources. The intensity is defined by a
coefficient (with a value between 0 and 1).
Typically, a shiny metal surface would have a diffuse reflectance value close to 0, while a piece of
cardboard would have a value probably above 0.9.
Specular: intensity and color of light reflected in one particular direction (highlights).
Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a
higher value to generate large specular spots creating a duller effect.
Typically, a polished object would have a high value for the specular reflectance coefficient, while a more
mat surface would have a lower one.
Roughness: dullness of an object (size of the reflecting zone).
Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a
higher value to generate large specular spots creating a duller effect.
Transparency: the degree of transparency of an object.
The higher the value, the more transparent the object (in the example the value is 0.75), the lower the value,
the more opaque the object.
Refraction: degree of light refraction passing through an object. The refraction is defined by a coefficient
(value between 1 and 2).
Set to 1, the transparent object will show no light distortion. As an example, water has a 1.2 coefficient.
This parameter is relevant for rendering purpose only.
Reflectivity: degree of reflectivity of an object. Set to a high value, the object reflects its environment.

Note that Photo Studio does not handle refraction (i.e light deviation at
transparent boundaries) but only transparency (i.e light is not bent by
transparent boundaries).

A preview is displayed in the Properties window but it slightly differs from the rendered image. Here are a
few examples of rendered images with their corresponding lighting properties:

Lighting Preview

Quick Render

6. Click OK.
The material attributes are defined.

Advanced Tasks
Scene Definition
Scene Tuning
Catalog Browsing

Scene Definition
Creating a Scene
Animating Scene Elements in a Simulation

Creating a Scene
This task gives you a methodology to define the parameters involved in the scene
creation, i.e. light, camera, textures.
Open the RED-CAR.CATProduct document.
Select also the Apply Customized View
icon from the View->Render Style menu in
order to check that the Shading and Materials options are on.

1. Create an empty environment (either box, cylindrical or spherical).
2. Choose the point of view you want to use then click the Create Camera icon

.

3. Click the Create Spot Light icon
to define a conical light source then orientate
the light as you wish with the help of the light preview on the environment walls.
4. Select the Light View command from the specification tree to make sure you have
the desired illumination. This command lets you see the light point of view. Only the
lit elements contained in the light preview shape will be lit at rendering time.
Set the lighting attenuation in order that it does not end
before the environment, otherwise the environment will be
almost entirely shadowed.

to make a quick render from the light view.
5. Click the Quick Render icon
Perform as many modifications as necessary and check that what you get is really
what you want to lit.
6. Click the Camera item in the specification tree then select the Camera View
command from the contextual menu.
You can then perform changes and make quick renders to adjust the
frameset to your needs.
7. Apply a texture on your environment and your part(s) by clicking the Apply Material
icon

and check the result by creating a quick render.

Once you are satisfied, you can create a shooting to have a finer result. To
do so:
8. Click the Create Shooting icon

to define the shooting parameters.

We advise you not to modify the default shooting
parameters except those concerning accuracy. When the
accuracy parameters is set beneath the mid value, you
should obtain a result nearly as identical as the quick
render.
9. Select a material in the specification tree then choose the Properties command
from the contextual menu to adjust the material parameters.
10. Click the Render Shooting icon
to check the result then go back to the material
Properties to correct the parameter definition if necessary.
Here are a few tips for lighting parameters:
contrast: start by setting the Contrast to the minimum intensity: when
you define the material lighting, the sum of all parameters (except
Shininess) should be roughly equal to 1 to render the material with
realism, but nothing forbids you to choose higher or lower sum values
to achieve special effects: they may simply be harder to control.
luminosity: use very carefully the Luminosity parameter ("good"
values are around 10%) to avoid final color saturation
reflectivity/shininess: set the Reflectivity and the Shininess at the
same time
transparency: if the material is transparent, define a Transparency
value.
We recommend you to define this parameter at the end.

11. When the result is satisfactory, adjust the shooting parameters to refine the result
such as the reflection number, the anti-aliasing, etc. in the Shooting Definition
dialog box.
12. Click OK when you have finished.
The scene is defined and ready to be rendered.

Animating Scene Elements in a
Simulation
This task shows you how to animate the various elements composing the scene, i.e.
cameras, lights, environments and materials.

The method is identical whether you animate a camera, a light, an environment or a
material, thus we will use only one of these objects to illustrate this task.

Open the REFLECT.CATProduct document.

1. Select the object you wish to animate, the light in our example.
2. Click the Simulation

icon. The Preview and Edit Simulation panels appear:

If you click the icon without having selected any element, the Select dialog
box opens and let you choose the element to be animated:

The Edit Simulation dialog box appears when you click OK.
Note: running the Simulation command positions the compass over the
element to be animated, which lets you manipulate it very easily as shown
below:

4. Modify the lighting properties such as the attenuation starting point or the angle
ratio.
5. Click the Insert button to record the desired keyframe and insert it into your
simulation scenario.
As you insert your first keyframe, the dialog box buttons are grayed out to let
you Modify, Delete or Skip the recorded shots.

The initial position is automatically recorded. If you need
to reposition your object, just delete its first position or
modify it.

6. Select the interpolation which defines the number of steps between the shots you
have recorded.

Assigning a high number of interpolations amounts to replaying the scenario
at a very low speed.
Note: the interpolation is used for preview only and does not affect the
rendered animation.

7. Use the other VCR buttons to play backward, step forward, modify the speed, etc.

8. Click the Play Forward button

to preview the animation.

You can also use one of the loop modes to:
run the simulation once
run the simulation in a continuous way
run then reverse the simulation in a continuous way.
9. Click the Edit simulation objects button to modify the object parameters. The Edit
Simulation Objects dialog box opens:

10. Select the simulation object to edit from the proposed list then click the Edit... button
to open the Properties dialog box:

11. Modify the object parameters as desired then click the OK button twice to close the
Properties and Edit Simulation Objects dialog boxes.

If you wish to animate more elements in your simulation,
click the Add... button. This opens the Select dialog box
and enables you to select additional objects:

12. Modify the object position and parameters as often as necessary, clicking the Insert
button to record each of the desired shot. You can also change the viewpoint:

13. Replay your simulation with the "Animate viewpoint" option checked:

The simulation is replayed and shows the viewpoint changes you recorded:

Note: this option can be activated whenever you want, either before recording
the simulation or after.
You can activate the "Automatic insert" at any time. This
option records the shots automatically as you move the
object as often as necessary.

14. Click OK to save your simulation.

Scene Tuning
Tuning Light Sources for Rendering
Tuning Materials for Rendering

Tuning Light Sources for Rendering
This task gives you some tips to help you tuning the light source parameters when
rendering a scene.
Open the TuningLightsStart.CATProduct document.
Select the View->Render Style->Customize View menu in order to check that the Shading
and Materials options are on. Select also the perspective view (still from the View->Render
Style menu).
1. Create a Quick Render

.

Step 1 - No light source

In our example, we aim at creating a light source that matches the lighting of
the environment pictures, i.e. the sun light.
2. Create a Directional Light

then a Quick Render to check the result.

Step 2 - One directional light source
As you can see it above, the result is better but still not realistic enough.
Note: if there is not shadow cast on the pavement, edit the Bottom wall
properties then check the Shadows "On" option under the Lighting tab.
3. Modify the light orientation using the green manipulators so that the red car shadow
matches the shadows of the cars parked behind. For our example, a correct position
would be:
origin in top rear left
target in bottom front right
Changing the viewpoint may be helpful to position the light (for example you
can use the Top or Left view).
4. Double-click the camera to go back to the original viewpoint then create a Quick
Render.
When using spot or point lights, pay attention to the lighting
end in order to make sure that the light cone includes the
object and thus, correctly illuminates it. Otherwise, the object
will be too dark.
For more information on light sources, refer to Defining a Light
Source in this guide.

5. For a more realistic lighting, you may need to create soften shadows.
To do so, simply duplicate the original light (Copy->Paste), slightly modify the
orientation of the new lights then decrease the intensity (only one light cast shadows)
as shown in step 6:
6. Access the Lighting parameters in the Properties dialog box to soften the light and
give it a faint yellow color.

Intensity parameters: Red= 173, Green= 173, Blue= 167
Do not forget to check the Shadows option "On".
7. Edit the Lighting parameters of the duplicated light (intensity parameters: R=G=B=
80) then check the Shadows option "off" before creating a quick render.

You can use the Stop icon to interrupt the process as soon as an unsatisfactory
result is detected.
When using a spot or point light, changing the Attenuation may also make the
lighting more realistic.

8. When satisfied, Create a Shooting then Render it to check the result:

Shooting rendered from current viewpoint

Shooting rendered from camera viewpoint

Bear in mind that the more light sources, the more difficult the
tuning of the global illumination of the scene.

Having a look at the TuningLightsEnd.CATproduct document may be helpful to
check that your lighting parameters are correctly defined.
For more information on shooting creation, refer to Setting Image Quality
Parameters in this guide.

Tuning Materials for Rendering
This task gives you some tips to help you tuning the material parameters when rendering a
scene.

Open the TuningMaterialsStart.CATProduct document.
Select the View->Render Style->Customize View menu in order to check that the Shading
and Materials options are on. Select also the perspective view (still from the View->Render
Style menu).

1. Create a quick render to detect the material parameters which need to be modified:

Specular and Reflectivity parameters set to 0
2. Access the Rendering parameters in the Properties dialog box.
We will start by modifying the Red Paint color and lighting so that the material looks like
having the iridescent and reflective properties of the metal:

The paint color was assigned the following values:
Red=182
Green=6
Blue=24

Play with the Diffuse coefficient to adjust more precisely
the material lighting.
Do not forget that the Specular coefficient tunes intensity of
light coming directly from the light source, whereas
Reflectivity coefficient defines the amount of reflected light
coming from other objects (indirect light).

3. Click OK to validate before creating a quick render:

4. Access the Glass lighting parameters in the Properties dialog box . As for Red Paint,
the glass should be reflective and shiny:

The glass color was assigned the following values:
Red=30
Green=30
Blue=30

5. Click OK to validate then create a quick render.

Note: if you want the red car lighting to be similar to the one of the other cars (in
background), thus being as close as possible to reality, just set the Luminosity
value to 0.75.
The quick render result will be:

We suggest that you create a quick render after each
parameter modification to check the impact on the material.

6. Now let`s deal with the tyre color and access the Rubber material properties. The
following values have been applied:

The rubber color was assigned the following values:
Red=61
Green=61
Blue=61
7. When satisfied, validate your parameters then click the Render Shooting icon to check
the final result:

Shooting rendered from current viewpoint

Shooting rendered from camera viewpoint
For more information on shooting, refer to Setting Image Quality Parameters in
this guide.

Catalog Browsing
Browsing the Scene Catalog

Browsing the Scene Catalog
In this task you will learn how to browse the Scene catalog and instantiate its components.
Should you need further information about catalogs (creation, preview, query, and so on),
please refer to Using Catalogs in the Infrastructure documentation.

This default catalog is located under:
downloaddirectory/OS/startup/components/Rendering/Scene.catalog
where OS is the operating system, for example intel_a (Windows NT).

Open the RED-CAR.CATProduct document.

1. Open the Catalog browser dialog box by clicking the Catalog Browser
Scene catalog opens:

icon. The

2. Double-click a family from the list to display its components.
3. Click the selected component to see its preview as shown below:

4. Click the Table>> button to show/hide the catalog descriptions and keywords. By
default, the table is hidden.

As far as Shootings are concerned, many informations are provided in the Table
such as Name, Width and Height of the computed image, Texture, Shadows,
etc.
Note: no component is provided by default. You have to create the components
to be taken into account for the shooting or drag and drop existing elements to
include them in the catalog.
5. Instantiate the desired element by double-clicking it.
Then you just have to adapt the instantiated element to your product. In the example
below, the environment dimensions have been slightly modified so that the scene
looks more realistic:

You can also Copy->Paste or drag and drop the element directly onto the
product in the specification tree.

Workbench Description
The Photo Studio Version 5 application window looks like this:
Click the hotspots to see the related documentation.

Menu Bar
Scene Editor Toolbar
Animation Toolbar
Render Toolbar
Apply Material Toolbar

Menu Bar
This section presents the menu bar tools and commands dedicated to the Photo Studio workbench.
Many other operations are documented in the Version 5 Infrastructure User`s Guide.
Start

File

Edit

View

Insert

Tools

Windows

Help

Start
The Start menu is a navigation tool intended to help you toggle between different workshops. The contents of the Start menu
vary according to the configurations and/or products installed.
For...

See...

Infrastructure->Rendering Entering the Photo Studio workbench
For more information about the Start menu, refer to
the Infrastructure documentation.

File
The File menu lets you perform file creation, opening, saving and printing operations. Refer to the Infrastructure
documentation.

Edit
The Edit menu lets you manipulate selected objects. Please refer to the Infrastructure documentation.

View
The View menu lets you view document contents. Please refer to the Infrastructure documentation.

View - >Toolbars
For...

See...

Animation

Animation Toolbar

Apply Material

Apply Material Toolbar

Render

Render Toolbar

Scene Editor

Scene Editor

Scene Editor Toolbar
For...

See...

Create Box Environment

Creating an Environment

Create Spot Light

Defining the Light Parameters

Create Camera

Creating a Camera from a Viewpoint

Animation Toolbar
For...

See...

Create Turntable

Creating a Turntable

Simulation

Previewing and Rendering a Turntable and Animating Scene Elements in a
Simulation

Apply Material Toolbar
For...

See...

Apply Material

Defining the Wallpaper + Refer to the Real Time Rendering documentation

Apply Sticker

Stickers

Catalog Browser

Browsing the Scene Catalog

Render Toolbar
For...

See...

Create Shooting

Defining Animation Parameters, Setting Image Quality Parameters

Render Shooting

Previewing and Rendering a Turntable, Setting Image Quality Parameters

Quick Render

Creating a Quick Render

Insert
For...

See...

Existing Component...

Loading Products

Tools
The Tools menu lets you perform image capture and album management, set user preferences and manage macros. lease
refer to the Infrastructure documentation.

Window
The Window menu lets you arrange document windows in relation one to the other. Please refer to the Infrastructure
documentation.

Help
The Help menu lets you get help on the currently active command and the product in general. Please refer to the
Infrastructure documentation.

Scene Editor Toolbar
This toolbar contains the following tools for creating and managing scene elements:

See Creating an Environment
See Creating an Environment
See Creating an Environment
See Defining the Light Parameters
See Defining the Light Parameters
See Defining the Light Parameters
See Creating a Camera from a Viewpoint

Animation Toolbar
This toolbar contains the following tools for creating turntables and animating scene elements:

See Creating a Turntable
See Previewing and Rendering a Turntable and Animating Scene Elements in a Simulation

Render Toolbar
This toolbar contains the following tools for creating shootings and launching renderings. Note that
this toolbar is only available in the CATIA Photo Studio product line.

See Defining Animation Parameters, Setting Image Quality Parameters
See Previewing and Rendering a Turntable, Setting Image Quality Parameters
See Setting Image Quality Parameters
See Creating a Quick Render

Apply Material Toolbar
This toolbar contains the following tool for applying materials and stickers as well as browsing
material catalogs. Note that these functionnalities are only available in the ENOVIA Portal DMU line
of products.

See Applying Materials in the CATIA - Real Time Rendering Version 5 Guide.
See Applying Stickers
See Browsing the Scene Catalog

Customizing
This section describes the different types of setting customization you can perform. All tasks
described here deal with permanent setting customization.
These tasks are:

Rendering Display
Rendering Output
Stickers

Rendering
This task explains how to customize Rendering display and output settings as well as
sticker mapping and adjustment.

Rendering Display
1. Select the Tools->Options... command then in the Infrastructure category, click the
Rendering sub-category.
The Display tab appears:

Setting Light Display
This area lets you control the display of inactive lights:
check the "No display for inactive lights" option to turn off inactive light display
check the "Full display for inactive lights" option to turn on inactive light display.

Setting Environment Display
This area lets you to set the type of environment display:
check the "No display for inactive environments" option to turn off inactive
environment display
check the "Simplified display for inactive environments" option to display inactive
environments in a simplified way
check the "Full display for inactive environments" option to turn on inactive
environment display.

Setting Reflection Display
This area lets you define reflection parameters:
check the "Enable" option to update environment reflections on reflecting objects
check the "Consider wall textures" option to display wall textures on reflecting
objects
you can use the "Size in static" and the "Size while moving" options to indicate the
texture size used when the product geometry is still and when it is moved
the "Update threshold" field lets you specify the texture update threshold in
degrees
the "Computation passes" field lets you indicate the number of texture passes

Rendering Output
1. Select the Tools->Options... command then in the Infrastructure category, click the
Rendering subcategory.
2. Click the Output tab:

3. In the Image Size area, specify whether the image size is defined "From active
viewpoint" or "Fixed". If you selected the "Fixed" option, you must then enter the image
width and height in pixels.
4. In the Output area, indicate the output type, i.e. On screen or On disk. If you selected
the " On disk" option, you must then specify the new path and the new name of the
image.

Stickers
1. Select the Tools->Options... command then in the Infrastructure category, click the
Rendering subcategory.

2. Click the Sticker tab. Two options are on:

3. In the Sticking area, deactivate the Gizmo automatic center option if you do not want to
the gizmo to be automatically centered when applied in Planar Projection mode.
This may be useful to adjust different parts of a same sticker on adjacent faces.
4. In the Layout area, deactivate the Absolute scale option if you do not want to use
absolute scale values when adjusting the sticker.
These values are those displayed under the Adjustment tab of the Stick dialog box. The
default relative scale is 1.00 which corresponds to the optimum sticker covering on the
whole surface.
Note: this option is relevant in Planar Projection mode only. However, absolute values
are proposed in UV mode but they are approximative.

5. The Default Image area lets you replace the default sticker image with your own image.
icon to open the File
Simply enter the path to the user-defined image or use the
Selection dialog box which lets you browse your folders to the desired location.

Glossary
A
accuracy

A parameter enabling to define the degree of precision of the rendering
quality

animation

A rendering of successive positions of a product recorded in a simulation

anti-aliasing

A graphic design technique that involves adding colored pixels to smooth
the jagged edges of a graphic

attenuation

The action of lessening illumination

C
camera

A rectangular-shaped element with a lens used to specify the chosen
viewpoint to take the image

contrast

The intensity of light diffused by the object when lit by light sources

D
directional light

A light coming from a given direction (like the sun, for instance)

E
environment

A geometrical element, either rectangular, cylindrical or spherical, used to
simulate interior as well as exterior scenes

L
luminosity

The intensity of light emitted by any light source

P
part

A 3D entity obtained by combining different features

point light

A punctual illumination (like a bulb, for instance)

product

A 3D entity containing several components

property

The attribute or characteristic of an object that defines its state,
appearance or value

R
raytracing

A photo-realistic image resulting from the calculation of the path of light
reaching the product from various angles. Each pixel is created by
calculating the behavior of a number of rays from these different points
over the area covered by that pixel

reflection

A light wave returned from a surface

reflectivity

The ability to reflect light

rendering

A photo-realistic drawing of three-dimensional objects

S
scene

A reusable configuration enabling to put models on stage using cameras,
light sources, environments, turntables

shininess

The dullness of an object

shooting

A set of parameters used to define a rendering

specification
tree

An area of the document window reserved for viewing the design
specifcations of a part, presented in the form of a tree structure

spot light

A conical light

sticker

An image that can be mapped onto a face of a product

T
texture

An image that can be mapped onto a geometry

transparency

The degree of transparency of an object. The object transparency defines
its property of transmitting light so that elements lying beyond are seen

turntable

A revolvable platform enabling to generate a sequence of images
representing the model rotation around a user-defined axis

Index
A
accuracy
adjustment
sticker
ambient
lighting (material)
Animate viewpoint option
animation
parameters
replay
scene
Animation toolbar
anti-aliasing
Apply Customized View command
Apply Material command
Apply Material toolbar
Apply Sticker command
applying
sticker
attenuation (lighting)

B
box
environment

browse
catalog

C
camera
conical
cylindrical
focal length
lens
properties
Camera View command
Camera Window command
catalog
browse
description
keyword
scene
Catalog Browser command
commands
Apply Customized View
Apply Material
Apply Sticker
Camera View
Camera Window
Catalog Browser
Create Box Environment
Create Camera

Create Cylinder Environment
Create Directional Light
Create Point Light
Create Shooting
Create Sphere Environment
Create Spot Light
Create Turntable
Edit simulation objects
Edit-Properties
Environment Active
Fit All In
Insert Existing Components
Quick Render
Redo Render
Render Animation
Render Shooting
Render Single Frame
Save
Simulation
Wall Active
compass
conical
camera
Create Box Environment command
Create Camera command
Create Cylinder Environment command
Create Directional Light command
Create Point Light command

Create Shooting command
Create Sphere Environment command
Create Spot Light command
Create Turntable command
cylinder
environment
cylindrical
camera

D
diffuse
lighting (material)
dimensions
environment
dynamic reflections

E
Edit simulation objects command
Edit-Properties command
environment
box
cylinder
dimensions
properties
reflections
sphere

wallpaper
Environment Active command

F
Feature Properties
Fit All In command
focal length
camera
frame
shooting

G
gizmo

I
Insert Existing Components command
interrupt
render

L
layout
sticker
lens
camera

library (material)
Light On option
light source
tuning
lighting
attenuation
material properties
parameters
position
properties
shape
wall
lighting (material)
ambient
diffuse
properties
reflectivity
refraction
roughness
specular
transparency

M
mapping
sticker
material properties
lighting
materials

render
tuning
Menu
toolbar
modifying
sticker

O
output
render
oversampling

P
parameters
animation
lighting
rendering
picture
quick render
save
position
lighting
preview
turntable
properties
camera
environment

lighting
lighting (material)
sticker
texture

Q
quality
shooting
quick render
picture
Quick Render command

R
Redo Render command
reflections
environment
reflectivity
lighting (material)
refraction
lighting (material)
render
interrupt
materials
output
shooting
sticker
Render Animation command

Render Shooting command
Render toolbar
rendering
parameters
Rendering workbench
replay
animation
roughness
lighting (material)

S
save
picture
Save command
scene
animation
catalog
creation
Scene Editor toolbar
Shadows option
shape (lighting)
shooting
definition
frame
quality
render
Show shadows option
Simulation command

size
sticker
specular
lighting (material)
sphere
environment
sticker
adjustment
applying
layout
mapping
modifying
properties
render
size
transparency

T
texture
properties
toolbar
Animation
Apply Material
Menu
Render
Scene Editor
transparency
lighting (material)

sticker
tuning
light source
materials
turntable
creation
preview

W
wall
lighting
Wall Active command
wallpaper
environment
workbench
Rendering

